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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
l Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

l On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “clickMaxwell 2D > Excitations > Assign >Wave Port.”

l Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
l Emphasis
l Titles of publications
l Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon or a partial view of the ribbon is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached and to include software files as applicable. This
allows more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular window
or window tab is open. In this case, the help page associated with the command or open dialog
box is displayed automatically.
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1 - Introduction
Ansys Maxwell is an interactive software package that uses finite element analysis (FEA) to
simulate (solve) electromagnetic field problems. Maxwell integrates with other Ansys software
packages to perform complex tasks while remaining simple to use. Maxwell incorporates both a
set of 2D solvers and 3D solvers in an integrated user interface. This guide will focus on 2D
capabilities.

To analyze a problem, you specify the appropriate geometry, material properties, and excitations
for a device or system of devices. The Maxwell software then does the following:

l Automatically creates the required finite element mesh.
l Calculates the desired electric or magnetic field solution and special quantities of interest,
such as force, torque, inductance, capacitance, or power loss. The specific types of field
solutions and quantities that can be computed depend on which Maxwell 2D solution type
you specified (electric fields, DC magnetics, AC magnetics, transient fields and data).

l Allows you to analyze, manipulate, and display field solutions.

A sample geometry created with Maxwell appears below:

This model is actually a three-dimensional (3D) object. Maxwell 2D analyzes the 2D geometry as
a cross-section of the model, then generates a solution for that cross-section.

Getting Started with Maxwell®: A 2D Magnetostatic Solenoid Problem
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In addition to XY models, Maxwell 2D can take advantage of 3D geometry that exhibits rotational
symmetry about an axis to compute fields in an axisymmetric model. The geometry described in
this guide exhibits such symmetry.

The following figure shows the finite element mesh that was automatically generated for the 2D
geometry.

Dividing a structure into many smaller regions (finite elements) allows the system to compute the
field solution separately in each element. The smaller the elements, the more accurate the final
solution.

Introduction 1-2
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The Sample Problem

The sample problem, shown below, is a solenoid that consists of the following objects:

l Core
l Bonnet
l Coil
l Yoke
l Plugnut

The 2D diagram actually represents a 3D structure that has been revolved around an axis of
symmetry, as shown in the figure below. In this figure, part of the 3D model has been cut away
so that you can see the interior of the solenoid.

Introduction 1-3
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Because the cross-section of the solenoid is constant, it can be modeled as an axisymmetric
model in Maxwell 2D. Material properties, excitations, and boundary conditions must also be
appropriately modeled by an axisymmetric design.

Introduction 1-4
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Goals
Your goals inGetting Started with Maxwell: A 2D Magnetostatic Solenoid Problem are as
follows:

l Determine the force on the core due to the source current in the coil
l Determine whether any of the nonlinear materials reach their saturation point

You will accomplish these goals by doing the following:

1. Draw the plugnut, core, coil, yoke, and bonnet using theModeling commands.
2. Define and assign materials to each object.
3. Define boundary conditions and current sources required for the solution.
4. Request that the force on the core be computed using the Parameters section of the

project tree.
5. Specify solution criteria and generating a solution using the Add Solution Setup and

Analyze commands. You will compute both a magnetostatic field solution and the force
on the core.

6. View the results of the force computation.
7. Plot saturation levels and contours of equal magnetic potential via the Post Processor.

This simple problem illustrates the most commonly used features of Maxwell 2D.

Introduction 1-5
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2 - Setting Up the Design Environment
In this chapter you will complete the following tasks:

l Open and save a new project.
l Insert a new Maxwell design into the project.
l Select a solution type for the project.
l Set the drawing units for the design.

Open and Save a New Project
A project is a collection of one or more designs that is saved in a single *.aedt file. A new project
is automatically created when Ansys Electronics Desktop is launched.

To create a new project:

1. Double-click the Ansys Electronics Desktop icon on your desktop to launch
Ansys Electronics Desktop.

l You can also start Ansys Electronics Desktop by clicking
Start > All Programs > Ansys EM Suite [version] >Ansys Electronics Desktop
[version] from the Windows Start menu.

2. Click Project > Insert Maxwell 2D Design.

The new design is listed in the Project Manager tree. By default, it is named
Maxwell2DDesign1. TheModeler window appears to the right of the Project Manager
window.

3. Click File > Save As.

The Save As dialog box appears.

4. Locate and select the folder in which you want to save the project.
5. Type Solenoid in the File name box, and click Save.
6. The project is saved in the specified folder under the name Solenoid.aedt. Rename the

design:
a. Right-clickMaxwell2DDesign1.

A shortcut menu appears.
b. Select Rename.

The design name becomes highlighted and editable.
c. Type Solenoid as the name for the design, and press Enter.

The project and design are now both named Solenoid.

Getting Started with Maxwell®: A 2D Magnetostatic Solenoid Problem
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Note: The solution type and axis will be selected in a later step.

Specify a Solution Type
As mentioned in the introduction, multiple solution types are available, depending on the specific
application. For this design, choose aMagnetostatic solution.

1. ClickMaxwell 2D > Solution Type from the menus.

The Solution Type dialog box appears.

2. Select theMagnetostatic radio button.
3. In theGeometry Mode drop-down menu, select Cylindrical about Z.
4. ClickOK.

Note: Many commands in theMaxwell 2Dmenu are also available by right-clicking on
various sections of the Project Manager tree. For example, right-click on Solenoid
(Magnetostatic about Z) in the Project Manager tree and you can select and change
the Solution Type.

Set the Drawing Units
1. ClickModeler > Units.

The Set Model Units dialog box appears.

2. Select in (inches) from the Select units drop-down menu.
3. ClickOK.

Setting Up the Design 2-2
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3 - Creating the Geometric Model
In this chapter you will complete the following tasks:

l Use the rectangle drawing mode to create a solenoid plugnut.
l Create the solenoid’s core, yoke, and bonnet objects using the polyline command.
l Explore the use of keyboard entry mode in creating the coil, yoke and bonnet objects.
l Create the solenoid coil.
l Create the background object.

Create the Geometry

The solenoid model used in this example is made up of five objects: a plugnut, core, coil, yoke,
and bonnet. All objects are created using the Draw commands as described in the following
sections.

The dimensions of the solenoid are shown below. For axisymmetric structures, the axis of
symmetry is the Z-axis, and drawing is performed in the XZ plane with all objects in the X > 0
portion of the plane. You will use these dimensions, which are given in inches, to create the
geometric model.

Getting Started with Maxwell®: A 2D Magnetostatic Solenoid Problem
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The following pages step you through drawing this model.

Draw the Plugnut
First, draw the plugnut using the rectangle command.

To create the plugnut:

1. Click Draw > Rectangle.

The cursor changes to a small black box, indicating that you are in Drawingmode.

2. Select one corner of the rectangle by clicking at the (0,0,-0.2) location, and press the Tab
key to jump to the manual entry area in the Status Bar at the bottom of the screen.

3. Notice the Status Bar is prompting for the Opposite corner of the Rectangle. Type 0.3 in
the dX box, ensure that dY is set to zero, and type -1.0 in the dZ box. Press Enter to
complete the creation of the rectangle.

The default properties appear in the Properties window.

Creating the Geometric Model 3-2
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Note: The Properties window can be used to configure options for the selected
object.

4. In the Properties window's Attribute tab, change the Name (currently Rectangle1) to
Plugnut by clicking on Rectangle1. The field becomes editable and you can enter
Plugnut as the new object name.

5. Optionally, change the color of the rectangle to blue:
a. In the Color row, click the Edit button.

The Color palette dialog box appears.

b. Select any of the blue shades from the Basic colors group, and clickOK to return
to the Properties window. The object color change will not be apparent while it is
currently selected.

6. Optionally, in the history tree, expandModel > Solids > Plugnut, and double-click the
CreateRectangle entry to display the Command tab in the Properties window. It can be
used to view and edit the geometric data. For this example, we do not need to edit the
geometric data.

7. Optionally, when using the pop-up Properties dialog box, clickOK to close the
Properties window. A rectangle named Plugnut is now part of the model.

Draw the Core
Next, use the polyline command to create the core. Instead of selecting coordinates in the
modeler window as you did for the plugnut, you will be using the keyboard entry method to select
the line coordinates.

Keyboard Entry
When creating objects in the modeler, you can manually enter coordinates. Manual entry is
particularly useful when the dimensions fall between the grid spacing.

In order to manually enter points, click the Tab key to move the system focus from the drawing
window to the keyboard entry area of the status bar that allows entry of direct vertices or
dimensions depending upon the object being created. The status bar also contains prompts to
assist with the manual entry process.

Once in manual entry mode, you may continue to press the Tab key to switch between the entry
fields.

To create the core:

1. Click Draw > Line.

The cursor changes to a small black box, indicating that you are in Drawingmode.

Creating the Geometric Model 3-3
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2. Press the Tab key to switch the focus to the keyboard entry area at the bottom of the
screen.

Note: Do not move the mouse once the focus has switched to the keyboard entry
area or the system will revert back to mouse entry mode and any data that has
been manually entered will be lost.

3. Enter the coordinate (0.1, 0, 1.175) for the first vertex. Pressing the Tab key switches
between the fields for easy data entry. Press Enter once the coordinate data is entered.

Note: The first vertex may be outside the viewable drawing area. If so, hold down
the Shift key and move the mouse slightly. The mode will switch to Panmode.
While continuing to hold the Shift key down, press and hold the left mouse
button. Drag the mouse to pan the modeler window and make more of the
positive Z-axis available. Releasing the mouse button and shift key exits Pan
mode automatically.

4. The Status Bar now prompts for the next point on the line. Using the Tab key to switch
between fields, enter the values for the second point: (0.1,0,-0.175). Press Enter.

5. Continue creating the core object by entering each of the points in the table in succession.

X Y Z
0.2 0 -0.175
0.2 0 -0.125
0.3 0 -0.125
0.3 0 1.175
0.1 0 1.175

Table 1:

6. Press Enter twice for the final vertex.
An object named polyline1 is created, and the Properties window contains the default
information for the newly created object.

Note: Pressing Enter twice after entering the final vertex causes the modeler to
end the polyline creation process. Because the polyline creates a closed
polygon, a 2D sheet object is automatically created from the series of vertices.

7. Click the Attribute tab.
8. Change the Name to Core.
9. Optionally change the color of the Core object to green.

Creating the Geometric Model 3-4
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Draw the Coil
Now draw the coil object using the keyboard entry technique discussed in the previous section.

To create the coil:

1. Click Draw > Rectangle.

The cursor changes to a small black box, indicating that you are in Drawingmode.

2. Press the Tab key to switch the focus to the keyboard entry area at the bottom of the
screen.

3. Enter the coordinate (0.4, 0, 0.7) for the rectangle position. Pressing the Tab key switches
between the fields for easy data entry. Press Enter once the coordinate data is entered.

4. The Status Bar now prompts for the opposite corner of the rectangle. Using the Tab key to
switch between fields, enter the values for the dimensions of the coil. Type 0.4 for dX, 0 for
dY, and -1.5 for dZ. Press Enter to complete the creation of the rectangle.

Note: You may enter the exact location of the opposite corner of the rectangle by
switching the entry mode from relative to absolute using the drop-down list box.

5. In the Properties window's Attribute tab, change the Name (currently Rectangle1) to
Coil.

6. Optionally, change the color of the rectangle to Red.

Draw the Yoke
Next, use the polyline command to create the yoke of the solenoid.

To create the yoke:

1. Click Draw > Line.
2. Press the Tab key to enter keyboard entry mode.
3. Create the yoke object by entering each data point from the following table followed by the

Enter key.

X Y Z
0.35 0 -1.05
1.15 0 -1.05
1.15 0 0.8
0.35 0 0.8
0.35 0 0.75
1.1 0 0.75

Table 2:

Creating the Geometric Model 3-5
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X Y Z
1.1 0 -1.0
0.35 0 -1.0
0.35 0 -1.05

4. After Entering the final vertex, press the Enter key twice. An object named polyline1 is
created. The Properties window contains the default information for the newly created
object.

5. Click the Attribute tab.
6. Change the Name to Yoke.
7. Optional: Change the color of the Yoke object to purple.

Draw the Bonnet
As in the previous section, use the polyline command in keyboard entry mode to create the
bonnet of the solenoid.

To create the bonnet:

1. Click Draw > Line.

Press the Tab key to enter keyboard entry mode.

2. Create the bonnet object by entering each data point from the following table followed by
the Enter key.

X Y Z
0.35 0 0.8
0.5 0 0.8
0.5 0 0.95
0.425 0 0.95
0.425 0 1.177
0.35 0 1.177
0.35 0 0.8

Table 3:

3. After entering the final vertex, press the Enter key twice. An object named Polyline1 is
created.

4. In the Properties window's Attribute tab, change the Name to Bonnet.
5. Optionally change the color of the Bonnet object to light yellow.
6. Verify that the geometric model appears as shown in the following graphic:

Creating the Geometric Model 3-6
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7. Click File > Save to save all of the operations up to this point.

Create the Background (Region)
Define a background region box with the origin at (0, 0, -2) and the dimensions of (2, 0, 4).

To create the background region box:

1. Click Draw > Rectangle.
2. Type the box position (0, 0, -2) in the X, Y, and Z fields at the bottom of the screen, and

then press Enter.
3. Type the box size (2, 0, 4) in the dX, dY, dZ fields, and then press Enter.
4. Click the Properties window's Attribute tab.
5. Change the Name (currently Rectangle1) to Bgnd.
6. Set the transparency to 0.9:

a. Click the button for the Transparent property.

The Set Transparency dialog box appears.

Creating the Geometric Model 3-7
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b. Type 0.9 in the text box, and clickOK to return to the Properties window.

Note: Alternatively, the Draw > Region command may be used to create the
background object.

7. The final geometry should look similar to the following:

8. Click File > Save to save the final version of the model before moving on to defining
materials.

Creating the Geometric Model 3-8
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4 - Setting Up the Solenoid Model
In this chapter you will complete the following tasks:

l Assign materials with the appropriate material attributes to each object in the geometric
model.

l Define any boundary conditions and sources that need to be specified, such as the
source current of the coil.

l Configure the simulation to calculate the force acting on the core.

Assign Materials to Objects
The next step in setting up the solenoid model is to assign materials to the objects in the model.
Materials are assigned to objects via the Properties window. You will do the following:

l Assign copper to the coil.
l Define the material ColdRolledSteel (a nonlinear magnetic material) and assign it to the
bonnet and yoke.

l Define the material Neo35 (a permanent magnet) and assign it to the core.
l Define the material SS430 (a nonlinear magnetic material) and assign it to the plugnut.
l Accept the default material that is assigned to the background object, which is vacuum.

Access Material Database
To access theMaterial Database:

1. Select the coil object by clicking in theModel Window or by selecting it in the history tree.

2. Once you have selected the coil, click in the Material Value field of the Properties
Window and select Edit.

The Select Definition dialog appears to allow material definitions to be assigned to the
selected object. Before a material is assigned, the Coil is considered a vacuum:

Getting Started with Maxwell®: A 2D Magnetostatic Solenoid Problem
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Assign Copper to the Coil
In the actual solenoid, the coil is made of copper. To assign this material to the coil:

1. Scroll the database table to the definition of copper in the Material Manager.

2. Select it by clicking on the name field.

3. ClickOK.

The Properties window will now show copper in the Material Value field for the Coil object, and
Coil will be listed under copper in theObject list.
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Assign Cold Rolled Steel to the Bonnet and Yoke
The bonnet and yoke of the solenoid are made of cold rolled steel. Because this material is not in
the database, you must create a new material, ColdRolledSteel. This material is nonlinear —
that is, its relative permeability is not constant and must be defined using a B vs. H curve.
Therefore, when you enter the material attributes for cold rolled steel, you will also define a B-H
curve.

Select Objects and Create the Material

To select the objects and create the new material:

1. Select both the Bonnet and Yoke (click on the Bonnet and then, while holding the Ctrl
key down, click on the Yoke).

2. Click the Material Value field from the Properties window and select Edit from the drop
down menu to open the Select Definition window.

3. Select Add Material. The View/Edit Material window appears.
4. UnderMaterial Name, change the name of the new material fromMaterial1 to

ColdRolledSteel.
5. Change the Relative Permeability type field from Simple to Nonlinear by clicking in the

Type field to access the Nonlinear option. The Rel. Permeability value field changes to a
button labeled BH Curve.
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Define the B-H Curve For Cold Rolled Steel

To define the properties of cold rolled steel, use the BH Curve button to define a B-H curve
giving the relationship between B and H in the material.

To define the B-H curve, click BH Curve in the Relative Permeability value field. The B-H
Curve Entry window appears.

On the left is a blank H,B table where the H and B values of individual points in the B-H curve are
displayed as they are entered. On the right is a graph where the points in the B-H curve are
plotted as they are entered.

Note:When defining B-H curves, keep the following in mind:
l A B-H curve may be used in more than one model. To do so, save (export) it to a
disk file, which can then be imported into other 2D models.

l Maxwell 3D can read B-H curve files that have been exported from Maxwell,
enabling you to use the same curves for both 2D and 3D models. In this guide,
you will not be exporting them to files.
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Add B-H Curve Points for Cold Rolled Steel

To enter the points in the B-H curve:

1. Click in the table entry area under the H column, row 1.
2. Enter 0.0 for the minimum H value and press the Tab key.
3. Enter 0.0 for the minimum B value and press the Tab key.
4. Enter the rest of the values for the B-H curve from the following table, using the Tab key to

accept the entry and move to the next available cell.

H B
0.0 0.0
1080 0.858
1480 1.06
2090 1.26
3120 1.44
5160 1.61
9930 1.77
1.55e4 1.86
2.50e4 1.88
3.50e4 1.90

Table 4:

Note: Numeric values— like the minimum and maximum B and H values—may
be entered and displayed in Ansys Electromagnetics Suite’s shorthand for
scientific notation. For instance, 35000 could also be entered as 3.5e4. When
entering numeric values, you can use either notation.

5. The graph automatically updates as each data point is entered. The software
automatically fits a curve to the points you entered and displays a list of all B-H curve
points, as shown below:
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6. After you enter the last value, press Enter to exit data entry mode, and clickOK to return
to the View/Edit Material window.

Assign ColdRolledSteel to the Yoke and Bonnet

Now that you have completed the B-H curve entry, enter ColdRolledSteel into the database and
assign it to the selected objects:

To save and assign the new material:

1. ClickOK in the View/Edit Material window to save the material properties you have
entered for ColdRolledSteel— including the B-H curve you have just defined— and add
it to the material database.

ColdRolledSteel then appears highlighted in the database listing. The word Project
appears next to it in the Location field, indicating that this material is specific to the
Solenoid project.

2. ClickOK to assign ColdRolledSteel to the Yoke and Bonnet.
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Assign Neo35 to the Core
Next, create a new material Neo35, and assign it to the Core. Neo35 is a permanently magnetic
material.

Note: In the actual solenoid, the core was assigned the same material as the plugnut.
However, for this problem, a permanent magnet is assigned to the core to demonstrate
how to set up a permanent magnetic material.

Select the Object and Create the Material

To select the Core and create the material:

1. Select Core in the history tree.
2. Click the Material Value field in the Properties window and select Edit.
3. In the Select Definition dialog box, select Add Material. The View /Edit Material window

is displayed.
4. UnderMaterial Name, change the name of the new material to Neo35.

Select Independent Material Properties

In magnetostatic problems, only two of the four available material properties need to be
specified. In Maxwell, you may enter only the permeability(m) and the magnetic coercivity(Hc).
The values of the other two properties are dependent upon these properties, according to the
relationships shown below.

The values of the other two properties, magnetic retentivity, Br, and magnetization, Mp, are
computed using the relationships shown above. You may use the Calculate Properties for
drop-down menu to calculate one set of properties from the other.

To calculate the properties to be entered:
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1. From the Calculate Properties for... drop-down menu, select Permanent Magnet. The
Properties for Permanent Magnet window appears.

2. Enter 1.05 in theMu (relative permeability) field but do not press Enter.
3. Click on the check box next to Hc to deselect it.
4. Click on the check box next to Br/Mp to select it.
5. Enter 1.25 in the Br (magnetic retentivity) field and press the Tab key or use the mouse to

change the field focus. Values automatically appear in the remaining fields.
6. ClickOK to accept all the values and close the window. When using the Calculate

Properties window, all data is automatically transferred when the window closes.

The View/Edit Material window should now have the values for Relative Permeability and
Magnetic Coercivity.
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Manually Enter Material Properties

Optional - To enter the properties for Neo35 manually:

1. Enter 1.05 in theMu field.
2. Enter -947350.85 in the Hc field.

Because the Hc (magnetic coercivity) is a vector quantity, the window will update with
entry fields for the X, Y, and Z vector components to specify the direction of the vector.

Note: By default, most material properties in the database shipped with Maxwell
will be oriented along the x-axis (1, 0, 0) when a vector orientation is required.
Other orientations require the user to create a coordinate system and align the
material with it in order to change the orientation vector once it has been
specified in the material database.

Also, verify that theMaterial Coordinate System Type drop-down menu at the top of the
window is set to Cartesian.

3. ClickOK. Neo35 is now listed as a local material in the database.

Assign Neo35 to the Core

Now that you have created the material Neo35, all that remains is to assign it to the core and
specify the direction of magnetization.

By default, the direction of magnetization in materials is along the R-axis (or the x-axis).
However, in this problem, the direction of magnetization in the core points along the positive z-
axis. To model this, you must change the direction of magnetization to act at a 90o angle from
the default.

To assign Neo35 to the core:

1. Make certain that Neo35 is highlighted in theMaterial list.
2. ClickOK in the Select Definition window to assign the material Neo35 to the Core

object. In the Properties window, theOrientation property is automatically set toGlobal.

Create a Relative Coordinate System for the Magnet Orientation

The material properties must be aligned with a coordinate system, so you will now create one
that is rotated 90°.

1. ClickModeler > Coordinate System > Create > RelativeCS > Rotated.
2. Using the mouse, align the X-axis of the new coordinate system with the Z-axis of the

global coordinate system and click the mouse.
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A new coordinate system RelativeCS1 is created and automatically set to be the current
working coordinate system.

Note: You may also use keyboard entry mode to specify the new coordinate
system by pressing Tab on your keyboard. This will shift the focus to the data
entry area at the bottom of the screen where you can enter exact values for the
coordinate point, in this case (0, 0, 1). Pressing the Tab key also allows you to
navigate between the X, Y and Z entry boxes quickly.

Complete the Alignment of the Magnet

1. Make sure the Core object is selected.
2. In the Properties window select the Value cell next toOrientation. A drop-down menu is

displayed listing the coordinate systems available in the project.

3. Select RelativeCS1. This completes the alignment of the magnetic coercivity for the Core
object.

4. You may wish to return to the Global Coordinate system. To do so, in the history tree,
expand the Coordinate Systems entry, and selectGlobal, as shown in the following
figure.
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Create SS430 Material and Assign to Plugnut
Next, create a new material — SS430— for the plugnut. Like the material ColdRolledSteel, it is
a nonlinear material whose relative permeability must be defined using a B-H curve. The first
step includes selecting the plugnut and creating the material.

Select Objects and Create Material

To select the plugnut, and create the material:

1. Expand theModel\Solids entry in the history tree, and select Plugnut.
2. Click the Material Value field in the Properties window and select Edit.
3. In the Select Definition window, click Add Material.
4. UnderMaterial Name, change the name of the new material to SS430.
5. Select the Relative Permeability type field and change it from Simple to Nonlinear.

The value field changes to a button labeled BH Curve.

Define the B-H Curve for SS430

1. To define the B-H curve for SS430, click the B-H curve button. The B-H Curve Entry
window appears.

2. Enter the points in the B-H curve according to the table below:

a. Select the H column, row 1 and enter 0.0. Press the Tab key to accept the entry and
move to the next cell.

b. Use the Append Rows button to add 9 additional rows to the table to accommodate
the data below.

c. Enter the following points using keyboard entry.

H B
0.0 0.0
143 0.125
180 0.206
219 0.394
259 0.589
298 0.743
338 0.853
378 0.932
438 1.01
517 1.08

Table 5:
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H B
597 1.11
716 1.16
955 1.20
1590 1.27
3980 1.37
6370 1.43
1.19e4 1.49
2.39e4 1.55
3.98e4 1.59
7.69e4 1.645

3. After you enter the last value press Enter to accept the last data point and clickOK to
return to the View/Edit Material window.

Assign SS430 to the Plugnut

Finally, add SS430 to the material database, and assign it to the selected object:

To save and assign SS430:
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1. ClickOK in the View/Edit Material window to save the material properties you have
entered for SS430— including the B-H curve you have just defined— and add it to the
material database.

2. Make certain SS430 is highlighted. ClickOK in the Select Definition window to save the
material attributes you entered for SS430 and assign it to the Plugnut object.

Accept Default Material for Background

Accept the following default parameters for the background object Bgnd:

l The object Bgnd is the only object that will use the material assigned by default. At the
time an object is created, a default material is assigned and is visible in the Properties
window.

l The default material, vacuum, is acceptable to use for the Bgnd in this model.

Note: During the model creation process, the material may be assigned
immediately to the object before continuing to create the next object. This may
have some advantages because copying an object with a material assigned will
preserve the material assignment for the copy objects and may reduce the need
for material assignments.

Set Up Boundaries and Current Sources
After you set material properties, you must define boundary conditions and sources of current for
the solenoid model. Boundary conditions and sources are defined through the Boundaries and
Excitations entries in the Project Manager tree or through theMaxwell 2D > Boundaries and
Maxwell 2D > Excitationsmenus, respectively.

By default, the surfaces of all objects are Neumann or natural boundaries. That is, the magnetic
field is defined to be perpendicular to the edges of the problem space and continuous across all
object interfaces. To finish setting up the solenoid problem, you must explicitly define the
following boundaries and sources:

l The boundary condition at all surfaces exposed to the area outside of the problem region.
Because you included the background as part of the problem region, this exposed surface
is that of the object Bgnd. The solenoid is assumed to be very far away from other
magnetic fields or sources of current, so those boundaries will be defined as “balloon
boundaries.”

l The source current on the coil. The coil has 10,000 turns of wire, and one ampere flows
through each turn, so the net source current is 10,000 amperes.
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Note: Maxwell 2D will not solve the problem unless you specify some type of source or
magnetic field — either a current source, an external field source using boundary
conditions, or a permanent magnet. In this problem, both the permanent magnet
assigned to the core and the current flowing in the coil act as magnetic field sources.

Types of Boundary Conditions and Sources
There are two types of boundary conditions and sources that you will use in this problem:

Balloon
boundary

Can only be applied to the outer boundary. Models the case in
which the structure is infinitely far away from all other
electromagnetic sources.

Current source Specifies the DC source current flowing through an object in the
model.

You will assign boundary conditions and sources to the following objects in the solenoid
geometry:

Bgnd At the outer boundary of the problem region, the outside edges of this
surface are to be ballooned to simulate an insulated system. The edge
along the Z axis will not be assigned because it is the axis of rotation for
this Cylindrical about Z problem.

Coil This object is to be defined as a 10,000-amp DC current source. The
current flows in the positive perpendicular direction to the cross-section.

Set Source Current on the Coil
Before you identify a boundary condition or source, you must first identify the object or surface to
which the condition is to be applied. In this section, you will pick the coil as a source and then
assign a current to it.

To specify the current flowing through the coil:

1. Select the Coil object by clicking on the object in the Modeler window or selecting the
object from theModel\Solids entry in the history tree.

2. SelectMaxwell 2D > Excitations > Assign > Current. The Current Excitation window
appears.

3. Enter 10000 in the Value field, and ensure the units are set to Amps.
4. Ensure the Ref. Direction is set to Positive to indicate current flowing in the positive PHI

direction, in this case, into the screen.
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Note: Positive is in the positive Z direction for XY problems, and positive PHI for
RZ problems.

5. ClickOK to complete the assignment of the source named Current1 to the Coil object.

6. Current1 is now listed under the Excitations section of the Project Manager tree.

Assign Balloon Boundary to the Background
The structure is a magnetically isolated system. Therefore, you must create a balloon boundary
by assigning balloon boundaries to the outside edges of the background object.

To select the edges of the background to use as a boundary:

1. Click Edit > Selection Mode > Edges, select the three edges of the Bgnd object that
correspond to the open region as shown. Click the first edge and the click the remaining
edges while holding down the Ctrl key.
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2. ClickMaxwell 2D > Boundaries > Assign > Balloon.
3. The Balloon Boundary dialog box appears with Balloon1 in the Name field. ClickOK to

accept the default name.

Note: In Cartesian (XY) models, all outer edges may be defined as boundaries.
However, in axisymmetric (RZ) models, the left edge of the problem region
cannot be assigned a balloon boundary condition because the solenoid model is
axisymmetric (representing the cross-section of a device that’s revolved 360
degrees around its central axis). Instead, it automatically imposes a different
boundary condition to model that edge as an axis of rotational symmetry.

4. Balloon1 now shows up in the Project Manager tree under the Boundaries section.
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You are now ready to set up the force computation for the model.

Set Up Force Computation
One of your goals for this problem is to determine the force acting on the core of the solenoid. To
find the force on this object, you must select it and assign the force parameter. The force (in
newtons) acting on the core will then be computed during the solution process.

To select the core object for the force computation:

1. Click Edit > Selection Mode >Objects. Click on the Core object in the modeler window.
2. ClickMaxwell 2D > Parameters > Assign > Force in the menu. The Force Setup

window appears.
3. ClickOK to select the default name and assign the force computation to the Core object.
4. The force computation now appears in the Project Manager tree under Parameters.

You are now ready to set up the inductance computation.

Set Up Inductance Computation
In addition to the force on the core, the coil inductance is of interest.

To set up the inductance computation:

1. ClickMaxwell 2D > Parameters > Assign >Matrix in the menu. TheMatrix setup
window appears.

2. Click the Include check box next to Current1 to select the current excitation for use in a
matrix calculation.

Because there is only one excitation defined in this problem, the return current must be set
to the default (infinite); however, in an axisymmetric model the current returns in the coil
itself because it is rotated 360 degrees about the Z-axis.

3. ClickOK.
4. Click File > Save to save all the changes for boundary, excitation, and parameter setup.
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You are now ready to configure the solution criteria.

Setting Up the Solenoid Model 4-18

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



5 - Generating a Solution
Now you are ready to specify solution parameters and generate a solution for the solenoid
model. You will do the following:

l View the criteria that affect how Maxwell 2D computes the solution.
l Generate the magnetostatic solution: The axisymmetric magnetostatic solver calculates
the magnetic vector potential, Aφ, at all points in the problem region. From this, the
magnetic field, H, and magnetic flux density, B, can be determined.

l Compute the force on the core. Because you requested force using the Parameters
option, the force computation automatically occurs during the general solution process.

l View information about how the solution converged and what computing resources were
used.

Add Solution Setup
Use the default criteria to generate the solution for the solenoid problem.

1. In the Project Manager tree, right-click Analysis and select Add Solution Setup.

The Solve Setup window appears:
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When the system generates a solution, it explicitly calculates the field values at each node in the
finite element mesh and interpolates the values at all other points in the problem region.

Adaptive Analysis
In the Adaptive Setup section of theGeneral tab, configure the following to have the system
adaptively refine the mesh and solution:

1. Enter 10 in theMaximum Number of Passes field for the maximum number of adaptively
refined solution passes to complete.

This setting instructs the system to solve the problem iteratively, refining the regions of the
mesh in which the largest error exists. Refining the mesh makes it more dense in the
areas of highest error, resulting in a more accurate field solution.
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Note: After each iteration, the system calculates the total energy of the system
and the percentage of this energy that is caused by solution error. It then checks
to see if the number of requested passes has been completed, or if the percent
error and the change in percent error between the last two passes match the
requested values.

2. Leave Percent Error set to its default value of 1%.

The Percent Error field tells the software what target error to achieve within the number of
passes allowed. If this percent error is reached, the solution process will terminate even
though additional adaptive passes may be available. In most cases, the default refinement
value is acceptable to provide an accurate solution in reasonable time.

If any of these criteria has been met, the solution process is complete, and no more iterations are
done.

Parameters
The Parameters section of theGeneral tab allows the user to specify when requested
parameters should be solved. For this solution, make sure that the Solve Fields Only box is not
checked, which will allow the force solution to be calculated after each adaptive solution.

Mesh Refinement Criteria

On the Convergence tab, the Standard section refers to the mesh refinement to be used during
adaptive analysis.

1. Set the Refinement Per Pass to 30%, which tells the software to increase the number of
mesh triangles by up to 30 percent after each adaptive solution.

2. SetMinimum Number of Passes to 2 to force the system to solve at least two passes,
regardless of the solution accuracy calculated after the initial solution.

3. Set theMinimum Converged Passes to 1. Setting a higher number will force multiple
successive solutions to be below the Percent Error criteria before stopping the solution
process.

Solver Residual
On the Solver tab, leave the Nonlinear Residual field set to 0.0001.

This value specifies how close each solution must come to satisfying the equations that are used
to compute the magnetic field. All other fields should remain at their default values.

ClickOK at the bottom of the window to complete the Solve Setup process.
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Validate Design
Before running a simulation, it is best to validate its setup.

1. From theMaxwell 2Dmenu, select Validate Check. Alternatively, from the Simulation

tab, you can click the Validate icon.

The Validate Check tool runs, and after it is complete, the Validate Check window appears:

For this model, we see that the model, the design settings, and the simulation parameters were
checked and validated. If the tool finds any problem with your design, it will be reported in this
window. Make sure to address any of these issues before you run your simulation.

Start the Solution
Now that you have set up the solution parameters, the problem is ready to be solved.

To start the solution, underneath the Analysis entry in the Project Manager tree, right-click
Setup1 > Analyze.

The system creates the initial finite element mesh for the solenoid structure. A progress bar
appears in the Progress box at the bottom of the screen. It shows the system’s progress as it
generates the mesh and computes the adaptive solutions.

The solution may be stopped by right-clicking on the progress window as shown.
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Values you obtain for percent energy error, total energy, or force may differ slightly from the ones
given in this guide. Depending upon how closely you followed the directions for setting up the
solenoid model, the results that you obtain should be approximately the same as the ones given
here.

Once the solution process has completed, or in the case of an error, the Message Manager
window will display information regarding the reason for the solution process termination. In this
case you should see the following message:

Normal completion of simulation on server: Local Machine

Note: After a solution is generated, the system will invalidate your solution if you
change the geometry, material properties, or boundary conditions of the model.
Therefore, you must generate a new solution if you change the model.

Monitoring the Solution
You may monitor the solution progress while the simulation is running by right-clicking on the
solution setup entry in the Project Manager. The following information is available while the
simulation is running.
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l Profile displays the Profile tab of the Solution window, which lists the computer resource
(memory and computation time) usage for each process in the simulation and the running
total.

l Convergence shows the mesh size, error calculation, and delta energy for each adaptive
pass in the solution.

Note: If a problem does not begin to converge after several adaptive passes, the
problem is probably ill-defined— for instance, boundary conditions may not have
been specified correctly. If this ever happens, do the following to interrupt the
solution process:

1. Right-click the Progress Bar, and select Abort.
2. Check the problem definition, and then solve the problem again.

l Solutions displays the results of the parameter calculations; in this case, the force
calculated on the Core.

l TheMesh Statistics option displays theMesh Statistics tab of the Solution window. It
displays the number of triangles and various triangle properties for each object in the
solution.
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Viewing Convergence Data
Now that the solution has completed, you can review the solution information to judge the
accuracy and suitability of the solution. Right-click on Setup1 in the Project Manager and select
Convergence to monitor how the solution is progressing. Convergence information appears as
shown below. In this example, the system has completed five adaptive passes.

Note: Do not be alarmed if the values you obtain for number of triangles, percent
energy error, total energy, delta energy differ slightly from the ones given in this guide.
The results that you obtain should be approximately the same as the ones given here.

Solution Criteria
Information about the solution criteria is displayed on the left side of the convergence display.

Number of passes Displays how many adaptive passes have been
completed and still remain.

Target
Error

Displays the percent error value— 1%— that was
entered during Add Solution Setup.

Energy Displays the percent error from the last completed
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Error solution— in this case, 0.73137%. Allows you to
see at a glance whether the solution is close to the
desired error energy. Because this value is less
than the Target Error, the solution was considered
to be converged.

Delta
Energy

Displays the change in the percent error between
the last two solutions— in this case, 0.0047518%.

Completed Solutions
Information about each completed solution is displayed on the right side of the screen.

Note: Your individual solution may differ slightly due to machine differences and
meshing differences with each release of the software.

Pass Displays the number of the completed solutions. In the previous figure, 5 adaptive
passes were completed.

Triangles Displays the number of tetrahedrons in the mesh for a solution. In the previous
figure, the mesh used for the fifth solution had 1048 triangles.

Total
Energy
(J)

Displays the total energy of a solution in Joules. In the previous figure, the total
energy for the fifth solution was 2.0118 Joules.

Energy
Error (%)

Displays the percent energy error of the completed solutions. In the previous
figure, the energy error for the fifth solution was 0.73137%.

Delta
Energy
(%)

Displays the change in Total Energy between the current and previous expressed
as a percentage of the previous pass energy. In the previous figure, the Delta
Energy for the fifth pass was 0.0047518%.

Plotting Convergence Data
By default, convergence data is displayed in table format as shown in the previous figure. This
data can also be displayed graphically.

To plot the Energy Error computed during each adaptive pass:

1. On the Convergence tab, click the Plot radio button.

2. Use the drop-down menu to select Energy Error for the Y-axis.

The following plot appears:
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Displaying this data graphically often makes it easier to see how the solution is
converging.

3. Optionally, use the other commands under Convergence Display to plot the number of
triangles, total energy, or delta energy for all adaptive passes.

Viewing Statistics
Click the Profile tab to see what computing resources were used during the solution process.
The following screen appears:
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The time that the solution process began is displayed at the top of the box. Beneath it, the
following information is
displayed for each adaptive field solution and mesh refinement step that was completed:

Task Displays the name of the system command that was used
Real time Displays the time taken to complete the step
Cpu time Displays the amount of time taken by the CPU (central processing unit) to

complete the step
Memory Displays the amount of memory used
Information Displays the of number of triangles, number of CPUs, and various other

information for the process

If more data is available than can fit on a single screen, scroll bars appear.

Click the Close button at the bottom of the Solutions window. You are now ready to move on to
post processing the solution and evaluating the fields and parameters calculated for this model.
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6 - Analyzing the Solution
Now that you have generated a magnetostatic solution for the solenoid problem, you can
analyze it using Maxwell 2D’s post-processing features. In this section, you will

l examine the computed force values
l plot the magnetic flux and magnetic fields in and around the solenoid

View Force Solution
Now that the solution is complete, examine the results of the force computation.

To view the force results, right-click the Force1 entry under the Parameters section of the
Project Manager tree, and select View Solution.

The final force value computed during the adaptive solution appears as shown below. Note that
your values may differ slightly from those shown:
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The net force on the core is approximately 128 newtons, acting in the negative Z direction
(pulling the core down into the solenoid). There is no component of force in the R direction
because of the axial symmetry. Click Close to dismiss the window.

Plot the Magnetic Field
You will now create a field plot of the Magnetic Field in the entire problem region.

1. You must first select one or several objects in the problem region on which to create a field
plot. Click the mouse anywhere in the Modeler window and press Ctrl + A. This will select
all objects in the model.

2. From the Field Overlays section of the Project Manager tree (or theMaxwell 2D > Fields
menu), select Fields > H >Mag_H to plot the magnetic field magnitude throughout the
selected problem region.

The Create Field Plot window appears. By default,Mag_H and all the In Volume objects
are selected. Also note that the Solution field defaults to the LastAdaptive pass data to
plot.

Analyzing the Solution 6-2

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: A 2D Magnetostatic Solenoid Problem

3. Uncheck the Full Model option; you only want to plot the symmetry model. If this option is
checked, the software will plot the full model (with both sides of the symmetry).

4. Optionally, a plot on only the edge of the selected Volume may be obtained by checking
Plot on edge only.

5. Click Done. TheMag H plot shown below appears.
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6. Double-click on the color key to display a window for modifying plot properties. Click the
Scale tab.

7. Set the Num Division to 15.
8. Click the Use Limits radio button and enter 1000 in theMin field as shown in the figure

below.
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9. Click Apply and the plot will update with a new minimum field display.
10. Click Close. The plot should resemble the following one:

11. Click File > Save to save all of the operations up to this point.
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7 - Adding Variables to the Solenoid Model
Now you are ready to use Maxwell to solve the solenoid problem parametrically. This chapter
shows you how to do the following:

l Add a geometric variation to the solenoid model. This will define the distance between the
core and the plugnut as a variable that can be swept during the solution.

l Define a source current function and assign it to the coil
l Calculate the force acting on the core and the coil inductance as a function of core position
and coil current during the solution.

The Solenoid Model

The geometric design variable that you are going to define in this chapter represents the gap
increase from the nominal design between the solenoid’s core and plugnut. By varying the
distance between these objects, you can model the solenoid’s behavior over a range of core
positions. During the solution, deltagap parameter will vary from 0.0 to 0.5 inches, representing
a spacing between the core and plugnut of 0.075 to 0.575 inches as shown. The core never
actually touches the plugnut — there is a minimum air space of 0.025 inches.

1. Choose File > Save As from the menu and save a copy of the project to Solenoid_
param. This will become our parameterized project.
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Adding Geometric Variables
There are many way to parameterize a geometric model in Maxwell’s modeler. For this example,
you will use the Edit > Arrange >Move command and assign a variable to the move distance.
The variable can then be modified by a parametric analysis to move the core location for the
sweep analysis.

Other options for varying an object would be to use variables in place of exact coordinates in the
rectangle command used to create the core as an example. Then the corners of the rectangle
can be varied allowing the core to move and change shape as well. However, all variations of
geometric parameterization use the basic procedure you will follow here:

l Assign a variable to one or several points in the creation of a geometric object.
l Provide a default value for the variable.
l Specify the variable is to be used for optimization, sensitivity, or tuning analysis. Local
design variables are automatically available for parametric analysis.

l Indicate the range of values the variable may take during the parametric analysis.

Add a Variable to the Core Object
You will now add a simple linear movement to the Core object using the move command.

1. Select the Core object by clicking on it in the Modeler Window or by selecting it in the
history tree.

2. Choose Edit > Arrange >Move from the menu. The modeler switches to move mode and
prompts you for a reference point in the status bar.

3. Enter a reference point by clicking at the origin. Optionally, you may enter (0, 0, 0) in the
keyboard entry area of the status bar and press the Enter key.

4. Enter a target point along the Z-axis by clicking the mouse along the axis. Optionally enter
(0, 0, 0.2) in the keyboard entry area and press the Enter key.

Note: It is not important what points are selected for the move command. You
are just creating the move command in the model history. The exact movement
will be controlled by the variable you set up next.

5. After entering the target point, the properties window will update with the Command tab
as shown.
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Alternatively, you may have the Properties dialog appear if you have the option Edit
Properties of New Primitives set under theModeler Options command

Select the Value field of the Move Vector row and enter deltagap in the Z-axis direction. In
addition, make sure that the X-axis and y-axis movement is zero. Press Enter.

6. The Add Variable dialog will be displayed indicating that you have entered a variable in a
numeric data field.

Enter 0.0 in into the value field of the dialog as shown.

7. ClickOK to complete the geometric variable assignment.
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Set the Coil Current to a Variable
Variables may be used in material, boundary and source excitations as well as for geometric
movement or shape alteration. In this section we will modify the coil current excitation to make it
a variable available for parametric analysis.

1. In the Excitations area of the Project Manager tree, double-click the Current1 excitation to
open the Current Excitation window.

2. Replace 10000 in the value field with the variable curr and clickOK.
3. In the Add Variable dialog box, enter 10000 A into the value and unit fields as shown

below. ClickOK to complete the variable assignment.

Set Variable Ranges for Parametric Analysis
Once variables have been added to the project, you must specify the range over which you want
the variables to be varied in the analysis.

1. Begin by selectingMaxwell 2D >Optimetrics Analysis > Add Parametric. The Setup
Sweep Analysis window is displayed.

2. In the Sweep Definitions tab, click Add. The Add/Edit Sweep window is displayed with a
default variable selected.
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3. Verify that the variable is set to deltagap and Linear Step is selected as the sweep type.
Enter the Start, Stop, and Step size information from the following table.

Value Data
Start 0.000
Stop 0.500
Step 0.050

4. After entering the data listed, click the Add button to transfer the sweep spec to the table
on the right.

5. Switch the selected Variable to curr and the sweep type to Linear Count. Complete the
current sweep entry from the following table.

Value Data
Start 0
Stop 1500
Count 11

6. After entering the data listed, click the Add button to transfer the sweep spec to the table
on the right.

7. Verify that two sweep entries exist in the table on the right side of the window and click
OK.
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8. In the Setup Sweep Analysis window, select theOptions tab and check Copy
geometrically equivalent meshes. This will allow the simulator to reuse meshes for the
coil current variations and save meshing time and overall analysis time.

9. Also in theOptions tab, check Save Fields and Mesh.
10. Finally, select the Calculations tab. Click on the Setup Calculations button to display the

Add/Edit Calculation window.
11. Select Force under Category in the Trace tab and click the Add Calculation button.
12. Select L under Category in the Trace tab and click the Add Calculation button.
13. Select Done to return to the Setup Sweep Analysis window, which should now contain two

calculations to be performed during each parametric analysis step as shown below.

The basic parametric analysis setup is complete; however, it is instructive to note a few
additional capabilities of the Setup Sweep Analysis before dismissing the window.

l The Table tab can be used to edit individual entries or to add or delete entire rows of
the table.

l TheGeneral tab allows you to set the values for any variables the design may
contain that you have chosen not to include in a sweep. In addition, you can select
the solution process parameters by selecting a setup in the Sim Parameters area of
the window.
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l In theOptions tab, you specify whether you want to save the Fields and Mesh for
post processing purposes.

14. ClickOK to dismiss the window.

Redefining Zero Current Sources
The variable spreadsheet is now filled. It has 121 entries (called setups) in it, one for each
combination of the values of deltagap and curr. But you still have a little more work to do. You
swept the curr variable starting at 0 amperes; however, it would be a waste of time to solve for a
zero solution. In addition, because we want to re-use the mesh, we need to make sure that we
start off with a solution that will provide good meshing overall. Therefore, you need to edit the
spreadsheet and replace all the zeros in the curr column with -1 ampere.

To accomplish this, do the following:

1. In the Project Manager tree, double-click ParametricSetup1 in theOptimetrics folder.

The Setup Sweep Analysis window appears.

2. Select the Table tab.
3. Scroll through the table and change each row containing 0A for the variable curr to -1A.
4. ClickOK to complete the changes.

Save Variables and Parameter Setup

Having added variables for both the geometric variation and the coil current; as well as, defining
the sweep ranges for each, it is a good time to save the setup.

l Select File > Save.

The Solenoid_param geometry is saved and you are now ready to move on to the solution of
the parametric model.
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8 - Generating a Parametric Solution
Now that you have added physical constraints to the geometry and set up the parametric
variable table, you are ready to generate a parametric solution for the solenoid model. You will
do the following:

l Generate the magnetostatic solution for each variant on the original model.
l Compute the force on the core as a function of the core position and the current in the coil.
(Because you requested force using the Parameters command, this automatically occurs
during the parametric solution process.)

l Compute the inductance in the coil as a function of core position and the current in the coil.
(Because you requested coil inductance using the Parameters command, this
automatically occurs during the parametric solution process.)

l Review the Convergence, Profile, and Force results of the Parametric analysis.

Model Verification
You can quickly verify that the spreadsheet contains only valid geometric sweep parameters for
the geometry. To verify the model:

1. Select View/Animate.The create animation setup window appears:
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2. Enter 0in for Start, 0.5in for Stop, and 15 for the number of Steps. These values are
consistent with the values used in the sweep setup.

3. ClickOK.
4. The Animation dialog box is displayed. Click Animate and the modeler window shows

the geometry animated with the motions of the Core object over the range of values for
deltagap.

Note: Over the range of values used for deltagap, there is no geometry overlap.

5. Click Close in the Animation dialog box to end the model animation.

Solving the Nominal Problem
Now that you have examined the geometric parameters, the problem is ready to be solved. As a
general practice, you should first solve the nominal problem to make sure that the problem is set
up correctly. If the nominal problem solves properly, then the parametric solution should be
sufficient.

To solve the nominal problem:

1. In the Project Manager tree, right-click Setup1 under Analysis and select Analyze.

A solution is generated for the nominal values of the solenoid parameters.

2. Once the solution has completed, right-click Setup1 under Analysis and select
Convergence to view the results. If the solution progressed normally, you will see the
number of Triangles increasing with each pass, and the Energy Error decreasing to less
than 1%.

Solving the Parametric Problem
You have set up your parametric table with each row to be solved. Depending on your computer,
each row will require a few minutes to solve. During the setup you selected Copy Geometrically
Equivalent Meshes which will improve the solution time; however, you may want to start the
solution when there is at least 10 to 15 minutes available for processing.

To start the parametric solution:

l Right-click ParametricSetup1 underOptimetrics in the Project Manager tree and select
Analyze.

The solution process begins.
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Note: Do not be alarmed if the values you obtain for percent energy error, total energy,
inductance, or force differ slightly from the ones given in this guide. The results that you
obtain should be approximately the same as the ones given here.

Monitoring the Solution
When performing a parametric analysis, the dual monitoring bar shown below is displayed in the
Progress window. The top bar displays the progress regarding the solutions in the analysis
table. In this case, 120 total analyses are to be performed as a result of the variation of the
deltagap and curr variables.

The bottom progress bar shows the standard progress in the solution of each individual row of
the analysis table.

Viewing Parametric Solution Data
During the solution process, you may view solutions, the solution convergence, and the solution
status or profile of any row in the table.

To view the parametric solution data during the solution process:

1. In the Project Manager tree, right-click Results and select Solution Data from the
shortcut menu.

The Solutions window is displayed. By default, the design variation is set to the Nominal
problem.

2. Click on the ellipsis button next to the design variation to display the Set Design
Variation window as shown.

Generating a Parametric Solution 8-3

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: A 2D Magnetostatic Solenoid Problem

3. Uncheck the Use nominal design checkbox.
4. Select any row in the table by clicking to highlight it and clickOK.
5. The design variation in the Solutions window now shows the profile, convergence

information, force, etc. associated with the selected variable values.

Viewing Parametric Convergence Data
After selecting a design variation, select Convergence to monitor how the solution is
progressing.

l For example, if you choose the variation corresponding to
Curr=-1A and deltagap=0.1in, then click the Convergence tab, you will see something
like what is shown below:
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l The mesh has been iteratively increased as shown in the Triangles column, and the
corresponding Energy Error has been decreased to less than 1%.

l You may change the View from Table to Plot by clicking the Plot radio button and
selecting which quantities should be plotted on the X and Y axes.

Plotting Parametric Convergence Data
In addition to viewing the results for each design variation, you may view the results as a function
of the design variable values.

1. In the Project Manager tree, right-click ParametricSetup1 under theOptimetrics folder
and select View Analysis Result.

2. Using the drop-down menu, select deltagap as the variable to plot on the X axis.
3. Select 1050A for the variable curr and clickOK.
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4. In order to review the Inductance of the coil, use the Y axis drop-down menu and select L
(Current1, Current1).
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5. You may inspect the performance at other values of curr by clicking the Set Other Sweep
Variables Value button and selecting the value of interest.

Viewing Parametric Solver Profile
Individual design variations may be inspected to see the solver profile as well.

1. In the Post Analysis Display window, select the Profile tab.

The following screen appears:

2. The Start, Stop and Elapsed time for each variation is shown in the table. Select
Variation 8 by clicking on it in the table.

3. Click the Solver Profile button.
4. The Solutions window is displayed with the selected design variation loaded and the

Profile tab selected.

The following information is displayed for each completed adaptive field solution and
mesh refinement step. If more data is available than can fit on a single screen, scroll bars
appear.
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Task Displays the system command that was used.
Real time Displays the time taken to complete the step.
CPU time Displays the time taken by the CPU to complete the step.
Memory Displays the amount of memory used.
Information Displays the number of triangles in the finite element mesh, size

of the matrix, disk space used and other information relevant to
the solution process.

5. Click Close to dismiss the Solutions window and return to the Post Analysis Display
window.

6. Click Close to dismiss the Post Analysis Display window.
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9 - Plotting Results from a Design Variation
With the result of design variations available, you can use the post processor to create reports
and plot fields with multiple variations. In this section, you will do the following:

l Create a report of force vs. gap with multiple traces for each current level
l Set the Design Variation for plotting fields from a design variation
l Animate a field plot using the Design Variation values for the gap

Access Parametric Post Processor

You will use the post processor to plot the force on the core as a function of position for different
values of coil current.

To access the postprocessor:

1. SelectMaxwell 2D > Results > Create Magnetostatic Report > Rectangular Plot.

Alternatively, right-click on Results in the Project Manager tree, and select Create
Magnetostatic Report > Rectangular Plot from the shortcut menu.

The Report window appears.

2. We want to plot force as a function of position, so make sure that the variable deltagap is
selected as the Primary Sweep variable.

3. Also, make sure that Force is selected under the Category list.
4. Click on the Families tab to set the values of curr to plot.
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5. In the Families tab, you may select Sweeps or choose individual variations for the
variable curr as shown.

6. Click New Report to plot the force versus gap spacing for various current values.
7. Click Close to dismiss the Report window and view the family of curves as shown below.
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Plotting Fields of a Design Variation
In order to plot the fields from a particular design variation, you must have told the software to
save the fields from the parametric analysis during the setup process. You did this in the "Set
Variable Ranges for Parametric Analysis" on page 7-4 section of this guide.

To plot the fields from a particular design variation, you must first "Apply Solved Variation"
below.

Apply Solved Variation
1. Tell the software which variation to use: select Results > Apply Solved Variation from

theMaxwell 2Dmenu or the shortcut menu.

The Set Design Variation dialog box is displayed as shown.
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2. Uncheck the Use nominal design option.
3. Scroll to the curr=1500A, deltagap=0.5in line and highlight it by clicking on it.
4. ClickOK to make it the new “Nominal Design” and be able to plot fields.

Note: The model view changes as the design variation is applied.

Plot Fields for the Variation
To plot the magnetic field for the variation:

1. Click Edit > Select All in the menu, or click in the modeler window and press Ctrl+A. All
objects in the model will be highlighted.

2. ClickMaxwell 2D > Fields > Fields > H >Mag_H.

The Create Field Plot window appears.

3. Click Done to accept the plot definition and create the field plot similar to the one shown
below.
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4. Right-click on the plot Key and selectModify from the shortcut menu.
5. Click on the Scale tab.
6. Because the field plot is dominated by the field in the core, click on the Log radio button to

see more field pattern in the low field regions. Make sure Auto is selected for the limits.
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7. Click Close to dismiss the window.

Animate the Field Plot Across Variations
In order to see how the field changes with the size of the gap you can animate the field as
follows:

1. In the Project Manager tree, right-click on Field Overlays, and select Animate.
2. The Setup Animation window appears.
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3. All values for deltagap are selected by default. ClickOK to accept, then click Animate to
view the field plot.

4. Click Export to save the animation as a .gif or .avi file.
5. Click Close in the Animation window.
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10 - Exit the Electronics Desktop
You have successfully completed the 2D Magnetostatic Solenoid Getting Started Problem.

1. Save the project plots and reports by clicking File > Save. Ansys Electronics Desktop will
save all data including the plots you have created for later use.

2. To exit the Ansys Electronics Desktop software, click File > Exit.
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